5 months ago Joomla! community announced the end of support for Joomla! 2.5 and its primary focus on Joomla! 3.x. Since December 2014 no further updates have been launched and no bug fixes have been made whereas Joomla! 3.x has been actively developed and maintained to comply with current technology and usability trends. Taking it into account we have come to a decision to discontinue the support of Joomla! 2.5 versions and focus on adding more value to Joomla! 3.x compatible extensions.

All our current customers who have acquired Joomla! 2.5 packages will be supported till the license expiration (18.05.2016) but no further updates will be added (the security releases will be provided on requests). New clients will receive only Joomla! 3.x package inside the acquired extension’s archives.

Since Joomla! 3.x offers more modern features and more third-party Joomla! developers will be discontinuing Joomla! 2.5 versions support (what can affect your website security and functionality) we encourage you to migrate your website to Joomla! 3.x. If you need help with the update, please send a ticket for a helpdesk department. We will be glad to assist you.

2015-05-11
Print