Home > Forum > Free extensions > JKayako bridge > Error in admin/views/config/tmpl/default.php
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Error in admin/views/config/tmpl/default.php

Error in admin/views/config/tmpl/defaul​t.php 7 years 3 weeks ago #14469

  • Dirk
  • Dirk's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
I replaced our Domain by [*DOMAIN_NAME*]...

The error_log says:
PHP Parse error: syntax error, unexpected '}' in /var/www/vhosts/[*DOMAIN_NAME*]/httpdocs/administrator/components/com_jk_bridge/views/config/tmpl/default.php on line 421, referer: http://[*DOMAIN_NAME*]/administrator/index.php?option=com_plugins&client=site

The file is located in

jk_bridge.1.0.0 (for Kayako 3.x).zip

in the compressed sub folder

\admin\views\config\tmpl\default.php

I located the error right at the end:

<? } } ?> should be <?php } } ?>

While I cannot attach files here, replace the code by:
<?php
echo $tabs->endPanel();
echo $tabs->startPanel("Com. Builder","cbbridge-page");
?>
<table class="adminform">
<tr><td width="185"><b><?php echo JText::_('JK_CONFIG_TAB3_COL1_TITLE'); ?></b></td>
<td width="185"><b><?php echo JText::_('JK_CONFIG_TAB3_COL2_TITLE'); ?></b></td>
<td><b><?php echo JText::_('JK_CONFIG_TAB3_COL3_TITLE'); ?></b></td>
</tr>
<?php
if( isset( $this->fields ) && count( $this->fields ) )
{
foreach( $this->fields as $field ) {

?>
<tr>
<td width="185">
<input type="hidden" name="kfields[]" value="<?php echo $field; ?>" />
<?php echo $field; ?>
</td>
<td><?php echo $field; ?></td>
<td><?php echo $field; ?></td>
</tr>
<?php
}
}
?>
</table>
<?php
echo $tabs->endPanel();
echo $tabs->endPane();
?>
</td></tr></table>
<input type="hidden" name="option" value="<? echo $option; ?>" />
<input type="hidden" name="task" value="" />
</form>

By the way: the "code" display feature does not work properly here at this board...
Last Edit: 7 years 3 weeks ago by Dirk.
The administrator has disabled public write access.

Re: Error in admin/views/config/tmpl/defaul​t.php 7 years 5 days ago #14706

  • Nana
  • Nana's Avatar
Hello,

Thanks a lot for this bug report.

We've fixed it. The latest version doesn't have it.

Now it works properly. You're welcome to check it. Just upgrade the component.

Regards
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.135 seconds